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File menu commands

The File menu offers the following commands:

New Creates a new graph. Closes the exiting graph if it exists.
Open Opens an existing graph data file.
Save Saves an opened graph using the same file name.
Save As Saves an opened graph to a specified file name.
Size Printed Graph Changes height(Y) and width(X) of a graph to be printed.
Print Prints a graph.
Print Preview Displays the graph on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Exit Exits Grafer.



Edit menu commands

The Edit menu offers the following commands:

Graph    Data Edit the X-Y data for the graph plot. Start here for a new graph.
Graph Options Edit graph Title, X-Y Axis Labels, and other data. 
Copy Copies the current graph to the clipboard as a Picture (Metafile).
Paste Pastes X-Y graph text from the clipboard into a graph.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Contents Offers you a list to topics on which you can get help.
Using Help Provides general instructions on using help.
About Grafer Displays the version number of this application.



Overview of Grafer

Grafer is designed to quickly produce a Line graph or Scatter plot to include in reports. Although the 
graphs are of adequate quality for publication, a need exists for quickly producing graphs to view 
developing data either for intermediate reporting or review by other people. This can be accomplished in 
Grafer with speed and ease.

Grafer makes a very close look-a-like to the graph specified by American National Standard, ANSI 
Y15.1M, which has been used for many years in the scientific fields. Scientists and engineers will find this
type of graph familiar and readily acceptable in their fields.

X-Y data can be placed in Grafer from a standard text file, the clipboard, or entered using the keyboard. 
Once the data is in Grafer a graph will be constructed automatically using the default Grafer parameters. 
The date is sorted by X value before plotting to assure a proper line graph is contructed. The new graph 
can be labeled    by changing the graph options in a dialog box.

When the graph has achieved the desired look, it can be saved in a text file that can be edited with 
Grafer, Notepad, or any other suitable text editor. The edited Grafer file can be reopened in Grafer to 
create a new graph. Using a printer with graphics capability, you can print copies to the size needed.

The completed graph can also be loaded on the clipboard and placed in a document as a Picture 
(Metafile). Once in the document, the graph can be adjusted to size (within limits) to fit the intended 
structure of the document. This will produce a much higher quality graph than a bitmap.



Make a Graph

Making a graph is a three step process.    First, you place the X-Y data in Grafer using one of the 
procedures described below. Next, you adjust the graph options until you have a satisfactory graph. Last, 
you save the graph to a file, print it, or place it on the clipboard to paste into another document.

A graph will be produced after you have the X-Y data in Grafer.    Data can be placed in Grafer in 
three ways as described below:

If the X-Y data is already in a text file, you can get it into Grafer by opening the text file as described 
in the Open dialog box. From File Manager, you can double-click on the Grafer file to open it providing
the file extension is .GRF. Grafer also supports the "drag and drop" method of file opening. From File 
Manager, using the mouse, you can "drag" any type of Grafer file and "drop" it in the open Grafer 
window or icon. 

If the data is saved to the clipboard in text format, it can be placed in Grafer by using the Paste 
command from the Edit menu. 

The data can be entered directly into Grafer by using the Graph    Data command from the Edit menu 
and entering the X-Y variables as described in Data to Graph dialog box help.

NOTE: The same format is used for all file, clipboard, or entered data as described in the Data to 
Graph dialog box help instruction referenced above.

Next, graph options such a Graph Title and Axis Labels, are edited by selecting Graph Options from the 
Edit menu. The graph options that can be changed are described in help for the Graph Options dialog 
box.

When the graph is completed, the other options available are:

Saving the graph to a text file using the Save As command from the File menu. This preserves the 
whole graph including data and labels in a text file you can later edit using Grafer, Notepad, or 
another text editor. The saved file can be later reopened in Grafer to recreate the graph.

Print the graph using the Print command from the File menu.    Before printing you can use the Print 
Preview command, also from the File menu, to see what the printed graph will look like. You can 
change the size of the printed graph by using the Size Printed Graph command from the File menu.

The graph can also be copied to the clipboard using the Copy command from the Edit menu. The 
clipboard graph is in the form of a Metafile and will Paste into other applications as a Picture.



Grafer Tips

The following tips will make Grafer more flexible and useful to you:

Grafer File Format Explains the structure of a saved file
Copying Graphs How to Copy graphs for best results
Graph Scales Adjusting the graph scales
Limitations Explains file size limits

Grafer File Format

When Grafer saves a file, the format is a text file that can be edited or created on any text editor such as 
Notepad. Using a text file format allows you to create the graph data on a word processor or spreadsheet,
copy it to the clipboard, and then import that data into Grafer using the Paste command. The format you 
should use for file or clipboard data is described below:

Note: <s> = a space or a tab character

<x1><s><y1>
<x2><s><y2>
<x3><s><y3>
<x4><s><y4>
<blank line>
<graph title>
<X axis label>
<Y axis label>
<X grid><s><Y grid><s><point type><s><point size><s><line type> 

or using actual graph data:

0 2
1 4
2 9
3 16
4 25
5 36

Grafer Test Graph
Graph X Values
Graph Y Values
5 4 1 0 1 

Note: This data is in file graftest.grf for your use.



Copying Graphs

When a graph is copied, Grafer creates a file that includes all of the graphic commands needed to draw 
the line segments and text for a complete graph.    This file is called a Metafile and it can be copied to the 
clipboard.    A Metafile is usually called a Picture.    Another application can then Paste the Picture 
(Metafile) graph into its document by executing all of the original graphic commands stored in the 
Metafile. The displayed graph is much higher quality than a bitmap and can be adjusted in size with little 
distortion.

The size of the Grafer display window will affect the appearance of the copied graph. Experience has 
shown that if a graph is about one-half full screen size it will copy more realistically to other applications. 
You may want to experiment for best results.



Graph Scales

Grafer uses automatic scaling for both the X and Y axis. The scaling software tries to generate scales that
display the data effectively using common minimum and maximum numbers that you may very well select
yourself. If the scales are not suitable, try adjusting the X or Y Grid Increments as described in the next 
paragraph.

The X and Y Grid Increments determine the minimum and maximum scale values and are adjustable from
the Edit menu item labeled, Graph Options. Just divide the scale range (maximum minus minimum) by 
the desired value between grid scale numbers to obtain the grid increment needed. Then, set the X or Y 
Grid Increment to that value to try a new scale.

For example, if the scale maximum is 100, the scale minimum is 0, and you want 25 units between scale 
numbers, calculate the Grid Increment as follows:

100 - 0
----------    =    4
      25

 



Limitations

The Grafer text files of X-Y data must be less than 65500 bytes. The number of data pairs represented by
this text will vary depending on the number of digits in each data pair. The floating point values in Grafer 
are represented with seven digits and can vary from 3E +/- 38. Data values exceeding seven digits in the 
text file will use up space and limit the number of points that can be graphed. Tests have shown that 
Grafer will handle over 3000 data pairs using a file as described above.

If your X-Y data file exceeds 29500 bytes you will not be able to edit the X-Y data in Grafer. This is a 
Windows limitation on the Edit control used for the Grafer editor. A similar limitation exists for the Windows
Notepad editor. The Write Windows editor will handle files up to the 65500 byte limitation of Grafer. Be 
sure and save a Write file in text mode.

You can add a graph title and axis labels, print, copy, and paste even if the data exceeds 29500 bytes.



New command (File menu)

Use this command to create a new graph.    For a new graph, select Graph    Data from the Edit menu and
enter your X-Y values.

If you have X-Y data on the Clipboard, you can create a new graph by selecting the Paste command. 

You can open an existing graph file with the Open command.

Shortcuts
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing file in Grafer format or a file containing just X-Y data pairs as 
described in the help section for the Data to Graph dialog box.

Results can be unpredictable if you open a file that is in another format. In almost all cases you will just 
get an error message box indicating that the file is not a Grafer file. The format for a full Grafer data file is 
described in the help section item, Grafer File Format. 

You can create a new graph with the New command.

Shortcuts
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

List Files of Type
Select the type of file you want to open.    Graph files do not need a special file extension.    Suggested
file extensions are TXT or GRF. All Grafer files are text files for easy editing.

Drives
Select the drive in which Grafer stores the file that you want to open. 

Directories
Select the directory in which Grafer stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the graph file to its current name and directory.    When you save a graph file 
for the first time, Grafer displays the Save As dialog box so you can name your graph file.    If you want to 
change the name and directory of an existing graph file before you save it, choose the Save As 
command.

Saving the graph preserves the whole graph including data and labels in a text file you can later edit using
Grafer, Notepad, or another text editor. The saved file can be later reopened in Grafer to recreate the 
graph.

Shortcuts
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the current graph file.    Grafer displays the Save As dialog box so 
you can name your graph file.    

To save a graph file with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new file name to save a graph with a different name.    A file name can contain up to eight 
characters and an extension of up to three characters.    Grafer adds the extension you specify in the 
Save File As Type box. Suggested extensions are TXT or GRF.

Drives
Select the drive in which you want to store the graph file.

Directories
Select the directory in which you want to store the graph file.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and file names listed at the bottom of the File menu to open the last four graph files you 
closed.    Choose the number that corresponds with the graph file you want to open.



Exit command (File menu)

Use this command to end your Grafer session.    You can also use the Close command on the application 
Control menu.    Grafer prompts you to save a graph file with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Graph Data command (Edit menu)

Use this command to edit or add new X-Y data to a graph. When you select this menu item, the
Data to Graph dialog box appears showing the data being used to construct the graph. If you have not 
entered data or opened a file with data, the edit box will be empty.

You create a new graph by entering X-Y data into the displayed edit box. Put one X-Y data pair on each 
line and leave a "space" between the X and Y values. When you leave the dialog box by selecting "OK", a
graph will be produced.



Data to Graph dialog box

X-Y data is added to the edit box by first entering an "X" value, then a "space" character, then a "Y" value.
Then, press "Enter" for a new line and repeat the above sequence for all of the X-Y data values you want 
to plot. The data entry would look like that shown below:

Note: <s> = a space character

<x1><s><y1>
<x2><s><y2>
<x3><s><y3>
<x4><s><y4>

 
or using actual numbers:

0    2
1    4
2    9
3    16

When you finish entering the X-Y data, click on the "OK" button to plot the data. If you change your mind 
about entering or editing the data just click on the "Cancel" button.

Very large or very small numbers can be entered using the letter "e" to identify the exponent.    Examples 
are: 1.2e8, 1.234E9, 3.21e-6, 4.67E-8



Graph Options command (Edit menu)
      
Use this command to edit the default graph settings such as graph Title, and X-Y Axis Labels. The Graph 
Options dialog box will appear allowing editing of all major graph features.



Graph Options dialog box

The following options allow you to specify a number of details for the graph:
Graph Title

This text is used for the title and is centered at the top of the graph.
X Axis Label

This text is used for the X axis label and is centered at the bottom of the graph.
Y Axis Label

This text is used for the Y axis label and is centered on the left side of the graph. The text is rotated 
90 degrees.

Point Type
Select the type of graph data point to use. Selections are None, Square, Circle, and X.

Point Size
Select the size of graph data point to use. Selections are Small and Large.

Line Type
Select the type of graph line to use. Selections are None, Solid, and Dashed.

X Grid Increments
Select the number of major divisions for the X axis.    A scale numeral will appear under each of the 
major divisions. Selections are 1 to 10.

Y Grid Increments
Select the number of major divisions for the Y axis.    A scale numeral will appear next to each of the 
major divisions. Selections are 1 to 10.

Graph Grid
Select the Check box to include a graph Grid. The Grid is useful for accurate interpolation of graph 
data.



Copy command (Edit menu)

Use this command to copy the current graph onto the clipboard.    This command is unavailable if there is 
no data to graph. The clipboard will contain a Picture of the current graph that can be Pasted into another 
document. The Picture, in the form of a Metafile, will be adjustable in size when Pasted. This format 
provides improved quality over a bitmap when printed. Use this method of putting graphs in your 
documents and reports.    See help item Copying Graphs for more detail.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Keys: CTRL+C



Paste command (Edit menu)

Use this command to copy graph data from the clipboard to the Grafer application. The graph data can be
prepared in another application such as a word processor, editor, or spreadsheet that supports copying to 
the clipboard such as Write and Notepad. The data is entered in the other application the same as 
described in the Data to Graph dialog box help item.

Since Grafer files are text files, you can prepare a complete Grafer file in another application and Paste it 
into Grafer for construction of the graph.    See Grafer File Format for how to construct the proper file.

This command is unavailable if the clipboard is empty.

Shortcuts
Keys: CTRL+V



Contents command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using Grafer and various types of reference information.    

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help command (Help menu)

Use this command for general instructions using Windows Help. If you have not used Help before, this 
command will assist you in getting started.



About Grafer command (Help menu)

Use this command to display the copyright notice and version number of your copy of Grafer.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 

border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Grafer window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    Grafer determines which window is 
next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    Grafer determines which window is
previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: CTRL+F4 closes a document window



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap to make the title bar visible.    This option does not affect 
applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available.





Print command (File menu)

Use this command to print a graph. This command presents a Print dialog box, where you 
may specify the number of copies, the destination printer, and other printer setup options.

Shortcuts
Keys: CTRL+P



Size Printed Graph command (File menu)

Use this command to change the size of a graph you want to print. The height (y) and width 
(x) of the graph can be changed in the dialog box that opens when this menu item is 
selected.



Print dialog box

The following options allow you to specify how the graph should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range 
Not applicable when printing a graph.

Copies
Specify the number of copies you want to print.

Collate Copies
Not applicable when printing a graph.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that output is sent to the printer.    The page
number indicates the progress of the printing.

To stop printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active graph as it would appear when printed.    When you 
choose this command, the main window will be replaced with a print preview window in 
which the graph will be displayed in printed format.    The print preview toolbar offers you 
options to move back and forth through the graph; zoom in and out of the graph; and initiate
a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box. You install
printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the graph is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.






